Re: Experimental version - 0.8.25

Stopwatch in countdown mode within the segment prior to the synchronization point should work. However the countdown mode only works if the stopwatch has a well defined range, specified by start and end points.

I think in your case you want to do the following:

  • Go to the begining of the segment.

  • Add the stopwatch object on the first frame.

  • Right click the stopwatch and choose "Start"

  • Move forward in time up to the synchronization point (shortcut: F8).

  • Right click the stopwatch and choose "Stop".

  • Right click the stopwatch again and choose "Countdown".

Re: Experimental version - 0.8.25

Faultyclubs wrote:
joan wrote:

I understand that there is now a missing feature of being able to record action in "pre-roll" fashion and considering various options.

Thanks Joan.   Yes, the removal of the recording delay feature, or the "pre-roll" capability as you call it,  is causing the problem.  I'm glad to see it's being worked on.   Sounds like you have a bigger picture in mind so it will be interesting to see what you come up with.   If i can provide input from the golf perspective I'm  happy to do that.

i'm glad to hear that you are working on it. there are several of us golfers using kinovea to do swing analysis and it's a really great program. thanks.

here's a link to a golf sim forum where we are talking about how to use kinovea for golf swing analysis if you are interested.
http://golfsimulatorforum.com/forum/pro … -s-awesome

Re: Experimental version - 0.8.25

Just to clarify, I'm not currently actively working on this. The top priority for 0.8.26 is to be able to export angle tracking timelines and update the Basler module to work with Pylon 5.

Re: Experimental version - 0.8.25

In version 8.23 I could save the movie with slowmotion factor. In the newest version, I can't. Is it moved to another menu?

Joop

Re: Experimental version - 0.8.25

Hi,

I'm having issues with this experimental version and my network camera. I've got this IP cam that I use with the url http://ip-address/now.jpg?snap=spush. However, when you save this configuration it deletes the characters from the ? onwards. Also, it seems impossible to use the ?-part with MJPEG.

Any ideas?

Thanks,
Marc

Re: Experimental version - 0.8.25

Joop wrote:

In version 8.23 I could save the movie with slowmotion factor. In the newest version, I can't. Is it moved to another menu?

Yes it is a regression, it hasn't moved to another menu.

Re: Experimental version - 0.8.25

mgerner wrote:

I've got this IP cam that I use with the url http://ip-address/now.jpg?snap=spush. However, when you save this configuration it deletes the characters from the ? onwards.

Thanks for the report. The parsing of the camera URL was indeed eating the "query" part. I just fixed it and should work again in the next version.

Re: Experimental version - 0.8.25

getpa wrote:

when saving the analysed video files, the option to apply the slow motion on the video is not available anymore.

Joop wrote:

In version 8.23 I could save the movie with slowmotion factor. In the newest version, I can't.

This should be fixed in the next version.

Re: Experimental version - 0.8.25

@Faultyclubs & @inorkuo,

I looked into the issue of recording with delay today and found a way to have it back without disrupting the architecture.
I still think the default option should be the optimized path from camera to disk, to ensure the most correct timing possible in the default case.

There will be a new option in the preferences to switch that "Recording mode".

In "Camera" mode it will record the current image coming from the camera. In "Display" mode it will record the current image displayed on screen. This second mode will thus take delay and mosaic view into account. It will not include any drawing overlays for now.

I'm not sure the labels "Camera" and "Display" are descriptive enough to intuitively understand what the options are doing, if someone can find a short and to-the-point explanation for each, that would be welcome.

http://www.kinovea.org/screencaps/0.8.26/0826-recordingmode.jpg

Re: Experimental version - 0.8.25

Another thing that will come into play is that the option defining the memory allocated for the capture buffers is no longer limited to 1GB. The max setting will be computed from the available physical memory.

This should allow much longer delays on x64 systems with more RAM.

Re: Experimental version - 0.8.25

That's great, thanks!

Possible explanation phrase might be:

Recording Mode:

- Camera (Record raw input stream)
- Display (Record displayed data stream)

Re: Experimental version - 0.8.25

joan wrote:

Thanks for the report. The parsing of the camera URL was indeed eating the "query" part. I just fixed it and should work again in the next version.

Thanks Joan, good to know! Is there any news on go-live of the new experimental version?

Re: Experimental version - 0.8.25

Dear all,
Did someone find the solution of tracking custom tools? I have made my own xml's but none of the custom tools allow me to configure and track in such a way that I can export it to Excel.
Please advice on this.
Kind Regards,
Alain