Re: Experimental version - 0.8.25

Hi joan, my Windows is in English and the language for non-unicode programs is in English too.

Re: Experimental version - 0.8.25

Please go to Help > Open log folder and collect the log.txt file and sent it over at joan at kinovea dot org. So I can better understand what is happening. Thanks.

Re: Experimental version - 0.8.25

joan wrote:
mgerner wrote:

I've got this IP cam that I use with the url http://ip-address/now.jpg?snap=spush. However, when you save this configuration it deletes the characters from the ? onwards.

Thanks for the report. The parsing of the camera URL was indeed eating the "query" part. I just fixed it and should work again in the next version.

Hi Joan,
When will you bring out a new experimental version? Would be good to have this fixed :-)

Re: Experimental version - 0.8.25

I can send a private test version if you need this urgently and promise to give feedback about it :-)
I don't know when the next experimental version is going to be finalized. I made good progress on the angular kinematics analysis and export which is the bulk of the release. But I'm abroad for about a month for work and I won't make much progress on Kinovea during that period.

Re: Experimental version - 0.8.25

joan wrote:

I can send a private test version if you need this urgently and promise to give feedback about it :-)
I don't know when the next experimental version is going to be finalized. I made good progress on the angular kinematics analysis and export which is the bulk of the release. But I'm abroad for about a month for work and I won't make much progress on Kinovea during that period.

Hi Joan,
Would be great to have a private experimental version. And yes, I'll send you testing results. Also, please let me know if you need any specific functionality to be tested.
Will you send me the information by email?
Marc

Re: Experimental version - 0.8.25

I try to view the track path. The marker is moving automaticly, but I don't see the path, or the three display possibilites. What do I wrong.

Joop

Re: Experimental version - 0.8.25

Right click the marker and select "End path edition", you should get the path. Right click the marker and select "Configuration" to get the display options.

38

Re: Experimental version - 0.8.25

hi, joan. i'd like to ask a few questions regarding the experimental version.  is it possible to change the label color somehow? when i track multiple objects i want to distinguish between them by using different colors. say, one group of objects is red and another one is blue. it was very useful feature in 0.8.15 version and now all the labels just stay black.

also, you've added some new 'trackable' tools. say, i have a video that lasts from point A to point E and i want to track 2 different objects using the spotlight tool (one from point B to point D and another one from point C to point E). right now it is impossible to do because there are no starting/ending points and both objects would be tracked from the start till the end of the video. may we expect this feature in near future?

thank you.

39 (edited by Chas Tennis 2017-Jul-30 16:55:46)

Re: Experimental version - 0.8.25

Kinovea Analyses on Vimeo

We often may want to communicate the Kinovea analyses videos using Youtube, Vimeo or other video web hosts.

This issue probably involves Vimeo website processing and I have not asked them yet.   I believe that Vimeo added single frame advance capability about 3 years ago. 

I cannot now recall some details so I'm not asking for a fix. Asking generally, how can I document problems with Vimeo processed Kinovea analysis videos in the future? 

I have uploaded some videos on Vimeo.   The Kinovea analysis videos worked well on my computer. They were side-by-side videos, each video recorded at different frame rates, 240 & 30 fps often,  with magnification boxes and millisecond countdown time displays.  Very informative displays.

1) sometimes the magnification boxes appeared on Vimeo in different screen locations than in my computer video.  In the wrong place, they blocked video and often obscured the labels, arrows etc that were on the screen.

I discarded the videos where the magnification box obscured something and am not now sure what might have been happening. It seems to work better lately but I worry about it. 

Why would everything be in place but the magnification box? 

Also, once a magnification box is introduced it stays throughout the video, start to finish. It would be a plus if they could be put in and removed for any ranges of frames.

2) often the Vimeo processed video would do single frame so that the faster video (say 240 fps) would advance 2 frames using the Vimeo process for single frame advance.

Vimeo single frame process - Hold down SHIFT KEY & use ARROW KEYS

This side-by-side video works well, magnification box is good, but the high speed video on the right advances 2 frame times each time the arrow is pressed. (8.4 milliseconds per Vimeo arrow press instead of 4.2 ms.) This video has very brief messages and is intended to stop on specific single frames when messages appear. Not a useful video for 30 fps playback.

I am so pleased with the great job that Kinovea does on these videos.  That Vimeo video is so near perfect except it advances 2 frames on Vimeo for every one frame advance key press.

I believe that I had set the video speed properly to 240 fps when making the Kinovea analysis video.

Might it work better if I put the 240 fps video to the left?  Probably a Vimeo processing or playback issue?

FYI - After years of suffering to advance one frame on Youtube, I just learned that Youtube single frame exists - you simply use the "." and ","  keys!!  Oh, that hurts!

40 (edited by Chas Tennis 2017-Jul-20 02:13:51)

Re: Experimental version - 0.8.25

Problem Working in Kinovea 8.25



Go full screen.

Video intended for single frame viewing of frames with text.  "Serve 1", "Serve 2" and "Serve 3" were analyzed and have text and angle scale, etc.

At the very end of this video at 48 seconds, for only a few frames, there is a brief green text box. It starts with "Forearm".......

When I was in Kinovea and making the original analysis video,  whenever I would double click on this green box to edit it,  instead the small & distant text box across the bottom would open up to be edited.  Small box - "Single Frame Vimeo".....  It became difficult to get the large green box because the small box kept opening up.  I'm not sure how I was able to edit it, but maybe I had to move the green box to open it.

41 (edited by Chas Tennis 2017-Aug-15 16:26:19)

Re: Experimental version - 0.8.25

Chas Tennis wrote:

Kinovea Analyses on Vimeo

We often may want to communicate the Kinovea analyses videos using Youtube, Vimeo or other video web hosts.

This issue probably involves Vimeo website processing and I have not asked them yet. .......................................................................................
I have uploaded some videos on Vimeo.   The Kinovea analysis videos worked well on my computer. They were side-by-side videos, each video recorded at different frame rates, 240 & 30 fps often,  with magnification boxes and millisecond countdown time displays.  Very informative displays.
..........................................................................................................
2) often the Vimeo processed video would do single frame so that the faster video (say 240 fps) would advance 2 frames using the Vimeo process for single frame advance.

Vimeo single frame process - Hold down SHIFT KEY & use ARROW KEYS

This side-by-side video works well, magnification box is good, but the high speed video on the right advances 2 frame times each time the arrow is pressed. (8.4 milliseconds per Vimeo arrow press instead of 4.2 ms.) This video has very brief messages and is intended to stop on specific single frames when messages appear. Not a useful video for 30 fps playback.

I am so pleased with the great job that Kinovea does on these videos.  That Vimeo video is so near perfect except it advances 2 frames on Vimeo for every one frame advance key press.

I believe that I had set the video speed properly to 240 fps when making the Kinovea analysis video.
.................................................

I contacted Vimeo about the issue of skipping frames when uploading  Kinovea videos to Vimeo.  Here is their reply.

" The original video you uploaded to Vimeo is 100 fps, which exceeds our 60fps threshold. We reduce the frame rate for all videos exceeding 60fps during our conversion process. Frame drops can occur during our conversion process in this case.

My best recommendation is that you re-encode this video using our compression guidelines https://vimeo.com/help/compression. "

I reviewed many of my Kinovea analysis video files and found some 30 fps, some 100 fps and some not listed.  (I have used 8.15 and 8.25) I thought all Kinovea videos were 30 fps and did not realize that many Kinovea files were 100 fps.  Skipping frames on videos above 60 fps appears to be an issue when uploading 100 fps Kinovea analyses video files to Vimeo. 

When does Kinovea save videos as 30 fps and when at 100 fps?    Is there a way to control the playback video frame rate before saving the Kinovea analysis video file on Kinovea 8.25?

Is there a similar issue uploading 100 fps Kinovea videos to Youtube?

42 (edited by arnopluk 2017-Aug-17 11:02:10)

Re: Experimental version - 0.8.25

Hello Joan,

Thank you for the great work on Kinovea so far. I am very interested in the 0.8.26 version of Kinovea, since it solves two issues I have been dealing with: 64bit buffer for delay; and recording of buffered video.

Next to those issues, I have found a small bug in the implementation of the hotkeys (in all versions I've tested):
When you use the keyboard to increase or decrease the delay, the GUI updates, but the actual delay isn't changed. In the code (below), the value is changed and the control is invalidated, but a 'ValueChanged' event is lacking.

In CaptureScreenView.cs (Ln 380-388):

                case CaptureScreenCommands.IncreaseDelay:
                    sldrDelay.Value = sldrDelay.Value + 1;
                    sldrDelay.Invalidate();
                    break;
                case CaptureScreenCommands.DecreaseDelay:
                    sldrDelay.Value = sldrDelay.Value - 1;
                    sldrDelay.Invalidate();
                    break;

Unfortunately, I can't get source code compiled in Visual Studio Community 2017 (.NET 4.7), so I can't propose a (tested) fix for this.

In SliderLogScale.cs (Ln 58-68):

        public double Value
        {
            get { return val;}
            set 
            {
                val = Math.Min(Math.Max(value, min), max);
                ValueChanged(this, EventArgs.Empty);                       // Changed
                Remap();
            }
        }

Kind Regards, Arno