I hope they didn't remove support for the .NET wrapper. Don't really have time to rewrite the Basler plugin from scratch at the moment. I see they removed the older SDK from the download area so it's not even possible to get 6.1.x without contacting them…

Most probably the difference is coming from the extra smoothing pass which is done for high speed footage for velocity and acceleration. This was added because the small time intervals amplifies the digitization noise on the derivatives.

For the next version I have added an option to disable this in the preferences so you can get the raw data. Disabling the main smoothing will also now impact how curves are drawn in the graphs and tracks.

edit: Actually this extra smoothing wasn't implemented for angular kinematics so I'm not sure where the difference could be coming from.

Most probably the device that recorded the 1000 fps video marked the file as 20 fps, this is common. You should go to menu Video > Configure video timing, and in the "High speed camera" section, set the frame rate to 1000.

Hi,
At the moment the data is not exported. It's not too hard to add I think, I'll look into it.

You can use right click at the end to choose if you want to keep or discard the last point. ("Finish polyline here" or "Finish polyline at previous point"). Once it is committed you can't add or remove points from the point list.

6

(11 replies, posted in General information)

Hi,
I can't reproduce the problems at the moment.

For the first one make sure you re-download the version 0.9.4 as the original one had a bug in it related to opening the configuration dialog on tracks.

For the second problem when the object is tracked it will have solid opacity during the tracking period, it should only fade out at each end, maybe it's this?

The problem was that the endpoint of the reference axis was set to be trackable, but since this is an abstract axis that is always defined in relation to the stationary arm it shouldn't be tracked. The inconsistent behavior comes from a conflict between the manipulation constraints system and the tracking.

I fixed it in the development version. It's also possible to fix it on your end by modifying the goniometer tool file manually:

<Kinovea program files>\DrawingTools\Custom\1 - Goniometer.xml

At line 45, remove trackable="true" (or replace it with trackable="false").

Interesting! thanks, I can reproduce the problem.

I re-released 0.9.4 with a fix for this as it was fairly critical.

10

(11 replies, posted in General information)

To all: I re-releaseed 0.9.4 with the fix for the crash when opening the tracking configuration.

11

(11 replies, posted in General information)

If you want to have the OpenPose body model show up in the toolbar as a button you can go to the program files, then under DrawingTools > Toolbars > player.xml, open this file and at line 12 un-comment the line, then restart the program.  That is, make this line look like this:

<subentry name="OpenPoseBody25" />

This tool is rather specific to importing data from OpenPose json files that's why it's not visible in the interface by default, the other two body models should be suitable for most scenarios.

Data created in 0.9.1 should already be imported normally in 0.9.4 and the OpenPose model should show up, does this not work?

Normally it should use the system's settings for the separator character. It's under Control panel > Region > Additional settings > Numbers > there is the decimal symbol and the list separator.
If the output from Kinovea is not consistent with this let me know as it would be a bug.

Yes indeed there is a work-in-progress manual. It's almost done but still needs some polishing.
It currently lives here: https://www.kinovea.org/help/staging/

I would love to get more feedback on this, whether some topics are missing/too complicated, etc. 
The current downloadable version does not contain the fix for tracking, as soon as the manual is complete it will be integrated in the software and the next version will be published, sorry for the delay in the meantime.

14

(36 replies, posted in General information)

Hi,
This is essentially an internal tool that is only used in the context of importing OpenPose files. For a human model you will want to use one of the two Human model tools. Unless there is something particular from the other one that you wanted to use?

Usually the problem with tracking drawings is the size of the search windows is not appropriate for the video. One tip is to work with a normal trajectory first to find the best parameters and then input these in the preferences as default tracking parameters in Options > Preferences > Drawings > Tracking.

15

(11 replies, posted in General information)

So in this case as the grid is set on the ground, it's measuring angles on the ground. The end points of the angles are considered to be on the grid and the angles calculated from that.

Even if you place the angles above the horizon, it will still calculate the coordinates as if they were on that calibrated plane. You can add a marker object and right click > "Display measure > Position" and then move it around to see this in action. (It will give weird values when it goes too much above the horizon that it can't project it on the ground anymore).

In this coordinate system these right angles are not right angles, you will need to set up the grid vertically.

Maybe the name perspective grid is a bit misleading, what it gives is a way to materialize the plane of motion.