Re: Experimental version - 0.8.24

hi well first thank you for this program, for me is a great tool of work and study, the experimental version is really great and fun tool to use, to teach and learn more about the human body.
I want to know if it possible the export the data to a excel or html file like, the option is open, but every time i try to export the text file or excel file, this just show me a lenguaje that can`t read, only trash.

thank you for the help

apsijas

Re: Experimental version - 0.8.24

If you are using the trajectory tool or point tool, maybe check the "Data analysis" contextual menu by right clicking the drawing.

From there you can export filtered data to a CSV file which should be read by any spreadsheet application, copy data to the clipboard, or directly export the graph as an image file.

The Excel export in the main menu will create a file in an XML format that is compatible with the version I had at the time, but I haven't checked with the most recent versions of Excel.

The text export option is mostly useful to use the data as input to another program. The CSV export from the data analysis window should be preferred in most cases anyway.

Re: Experimental version - 0.8.24

thank you very much, i hope can upload some of my work, best regards

apsijas

Re: Experimental version - 0.8.24

I have been using the experimental version for a while, but just noticed that when I try to save analysis data as a csv, it uses a ';' instead of a ',' which means i can't just open the file in excel. Currently I have to copy to clipboard, save as a text file and then import into excel using the semi-colon. This method is not ideal, so wondering if there is any way to fix this, of if I have to wait for an update to the program.
Thanks.

20 (edited by joan 2015-Jul-23 18:18:50)

Re: Experimental version - 0.8.24

I'm not a heavy user of Excel but I think there is a button in one of the ribbon tabs where you can specify the field separator character when importing.

The problem with using a comma is that in some locales like French it is the decimal separator and it would mangle numbers with one another. It could be an option in preferences though.

edit:
The button I mentioned will only work for copy/paste operation. It's irrelevant if you double click an exported file.
Apparently if you rename the file to .txt it will open the text import dialog which let you choose the delimiter.

Re: Experimental version - 0.8.24

In the next version the behavior will be to read the value under Control Panel > Region > Formats > Additional settings… > List separator. The value can be ";" or ",". Then use this value as the separator for exported files and clipboard data. It should provide at least self consistency for a single machine and will work without issue as long as the files are shared with users of the same culture.

It is also the value that is used by Excel at import. You can set it to ";" in the meantime if you don't fear loosing compatibility with other applications.

Re: Experimental version - 0.8.24

Thanks for that, never thought about the EU number system. I have been doing it the method you suggest, but would be awesome to set it via options. Thanks again for your great software.

Re: Experimental version - 0.8.24

joan wrote:

@cmdi035: I have seen this effect with some H.264 encoded content, is it your case? I don't have a solution at the moment. The images themselves should be in the correct order but the timestamps are all mangled which is why the cursors jumps back and forth, and why there are issues with seeking.

I'm a bit late, but I have found the problem with the h264 encoded content and the jumping cursor. The jumping cursor occurs when the h264 file contains b-frames. This type of frames needs for its decoding the previous and the following frame (en.wikipedia.org/wiki/Video_compression_picture_types#Bi-directional_predicted_frames.2Fslices_.28B-frames.2Fslices.29 and https://en.wikipedia.org/wiki/Group_of_pictures). If you want to decode a b-frame you first have to decode the following frame, so the timeline will jump forward to the timestamp of the following frame and then back to the timestamp of the b-frame.
To see if your video contains b-frames download the ffmpeg binary (win: ffmpeg.zeranoe.com/builds) and test it with ffprobe (

ffprobe.exe -show_frames videofilename.mp4 > outputfile.txt

). The outfile.txt contains informations about all frames of the video, so choose a small testclip or you get a huge txt-file :-) If you search in the file for "pict_type=B", you will find all b-frames.
You can avoid the problem, if you encode your h264 video without the b-frame feature (ffmpeg cmd switch: -b 0). Then the timeline will work properly, but your filesize will increase.

But I don't understand why the video never stops and repeats and why at the end of the video the velocity fades to 0.

@joan Fixing the problem of the "never ending video" would help a lot, because the usage of b-frames seems to be very common in h264 files.

Re: Experimental version - 0.8.24

Hi Joan,

We have just acquired our first Basler camera but are having difficulty getting Kinovea to stream a live image in via the Pylon drivers. The set up works via or 3D motion capture system and via Pylon viewer so I am confident the install is OK. I suspect I am simply not getting the setting right in Kinovea.

Is there a guide/manual outlining the process?

Many thanks
Dan

Re: Experimental version - 0.8.24

There is no written guidelines regarding Basler cameras at the moment.

Can you expand a bit?
- Which package did you download and install from Basler? Was it x64 or x86, and are you on Windows x64 or x86?
- Do you see the camera thumbnail or not?
- Do you have a color or monochrome camera?
- Do you have the same issues if you start by using the Pylon viewer, connect to the camera there, close the viewer, and then open Kinovea?
- Can you open the log.txt file and search for "Basler". Paste any corresponding line found.

Thanks

26 (edited by Turtle9er 2015-Aug-11 19:03:18)

Re: Experimental version - 0.8.24

Not sure if this has been covered before, but is there a way to improve the reverse frame-by-frame on a video. I love using the program, but has become very hard to use in the field since I can show an athlete the forward slow motion very easily, but if I try to reverse to show a slight change etc, it stalls and I have to wait for it to catch up. I try to set keyframes to help this, but not the best solution if I need to show many parts of the video and just want to quickly play it for an athlete.
Just wonder if there is any way to tweak this. Thanks again for a great product.
Sorry, forgot to include, most of my video is from a gopro, either 720p @ 240fps or 1080 @ 120fps.

Re: Experimental version - 0.8.24

Dear Joan,
dear community,
is there any possibility to save / preset the settings (i.e. object and search window size, color, label) of the extremely valueable path tracking tool (in the "configure trajectory tool" options)?
Have I missed a workaround stated somewhere?
Thanks a lot in advance!

- the repairman will never have seen a model quite like yours before -

Re: Experimental version - 0.8.24

Hmm. I was going to write that there was an options in the preferences but I just realized this is still only in the unpublished version. I really need to get it out.

Re: Experimental version - 0.8.24

big_smile
Yes, definetively!
THX for your reply
cheers

- the repairman will never have seen a model quite like yours before -