Topic: Camera advise - Logitech C922 Problems

Hey guys,

I'm sorry in advance for asking something that's eventually pretty basic (for you)...

I'm using Kinovea for a bike fitting setup indoor and it works perfectly when I record a video file (currently using a Canon G5X digital camera with shutter speed set to 1/1000) and analyse the file afterwards.

Now I want to take it a step further... live captured motion analysis.

I thought a cam with 60fps would do the job for the beginning, so I bought a Logitech C922. Unfortunately when I set it up and captured the image in Kinovea it only recorded 10fps @ 720. The maximum frame rate I could get was 30fps with 640, which definetly was not enough!

First question: I don't know how the resolution is connected to the frame rate?! Can someone explain this shortly?!

Second question: I already learned that the frame rate is very dependent on the light situation but it seems, no matter what I do, the C922 doesn't capture more than 10fps in its high res mode (the only mode that allows more than 30fps). Does anyone have the C922 and experienced that problem, too?

Third question: I returned the C922 already and I am now on the lookout for something different. Is there any recommendation you can give for a 60fps camera that works properly? What about that PS3Eye that's been talked about a lot. Or those "china cams" from Ebay?

Thankful for every help / comment!

Best,

Raphael

Re: Camera advise - Logitech C922 Problems

The C922 is among the best you can get.

Make sure you are using the most recent Kinovea version even if it's marked experimental, it has many improvements on the capture side.

The framerate and resolution are largely independent but together they define the total bandwidth that the camera has to process and then send over to the computer. The hardware itself is limited by the amount of data it can capture and then the USB link also has a limit to what can be transferred. USB cameras define a set of framerate and resolution combinations that can be selected.

When you go to the camera parameters dialog in Kinovea you will be able to select the stream format, the resolution and framerate. Resolution and framerate option availability depends on the stream format. Set the format to "MJPEG", this way the video will be compressed directly on the camera and the bandwidth to the computer will be much reduced, allowing to choose the top resolution/framerate combo without frame drops.

The PS3Eye has a really low resolution, I wouldn't recommend it in 2018. Some of the Chinese cameras can be interesting but I don't think they have anything above the flagship Logitech if you are looking for top resolution/framerate.

Re: Camera advise - Logitech C922 Problems

Dear Raphael,
C922 works fine if set the way joan described in his post! I use it with the latest x64 Kinovea version.
It works well even with "suboptimal" light conditions.
If you are looking for something else, give Logitech Brio a try.
There is another recent post in the forum on Brio with more information.
The PS3Eye is indeed not up-to-date anymore, though I am still using them in a very special set-up that cannot be realized with other cams.
Good luck!

- the repairman will never have seen a model quite like yours before -

Re: Camera advise - Logitech C922 Problems

hey guys i have a similar issue as Raphael.
I have a C922 and a Brio 4k.
The brio 4k works flawlessly over USB 3.0 with kinovea: 90 fps 720p, 60 fps 1080p and 30 fps 4k
Sadly the c922 only works well with 30 fps 720p or 30 fps 1080p, but doesnt work properly on 60 fps 720p, if i set it to this setting, it has a real fps rate ob 59,XX which makes recording with both cameras in sync at the same time impossible, as they get immediately out of sync (the brio4k is constantly at 30/60/90 fps as set).
I searched the internet, found that logitech suggests to turn off the low light option, but no difference.
I tried it on two rather powerful pcs - dell xps 9370 with i7 8550u, 16gb ram and ssd, as well as ryzen 1700x at 3,9ghz, 32gb ram and ssd. In both instances the c922 made the same issues and the brio worked flawlessly.
Does anyone have an idea? Is it just that the c922 is actually by design like  it (usb 2.0) and cant be helped, or do i ahve to change some settings, or perhaps mine is defective? Getpa you said you are very happy with it.
Thanks in advance

Re: Camera advise - Logitech C922 Problems

Hell Joan and others,

I tried to use a Logitech C922, but can't get it to record at more than 30fps. I have the latest experimental version installed, put the stream format to MJPEG and tried different resolutions, but I am only able to record at 30fps.
Is there something I am overlooking?
Best regards,

Hans

Re: Camera advise - Logitech C922 Problems

Make sure you set the exposure appropriately. For 60 fps you will need to set it lower than 16.6... ms. (Note: depending on the driver and some other things I'm not too clear about, this is sometimes displayed as an arbitrary number instead of milliseconds).

If you do not need to record the delayed stream, go to Preferences > Capture > Recording and make sure the option is set to "Camera". (Limitation that should be fixed soon).

When you say you are only able to record at 30 fps, do you mean that you cannot set the framerate higher in the camera configuration dialog, or that the "Signal" value in the infobar doesn't go higher than 30 fps, or that the resulting file looks to only have 30 frames per second even if it's marked as 60 fps?

Re: Camera advise - Logitech C922 Problems

I cannot set the framerate higher dan 30fps in the configuration dialog. I recorded the stream and then played it, and it surely wasn't higher than 30fps. Where can I set the exposure?

Re: Camera advise - Logitech C922 Problems

I don't have a C922 but the configuration dialog should look approximately like this:

https://www.kinovea.org/screencaps/0.9.1/cameraconf.png

If you don't see Exposure, something must have gone wrong while looking for the properties. Maybe the driver is not up to date?

Re: Camera advise - Logitech C922 Problems

Exposure is displayed as an arbitrary number. Changing the number doesn't seem to change the possibility to select a higher framerate. However, by selecting 'Display' in the Preferences > Recording Menu, I was able to solve the problem. When looking at the camera, it still says 30fps, but when I play it again, it plays at 60fps. Since I will be using it for bikefittings and thus have to record first, and then apply tracking of the measurements, this fixes my problem...

10 (edited by ReBalHans Bikefitting 2020-Jan-25 13:54:55)

Re: Camera advise - Logitech C922 Problems

Hello guys,

I'm afraid I'll need your help again. When doing my first bikefitting today, my camerasettings failed on me... I have a Logitech C920 (and a C922 but it has the same issue) and i'm using the latest experimental version of Kinovea. Suddenly I can only set it to 30fps maximum, regardless of resolution. On top of that, there is a lot of motion blur, which made it impossible to track the lights I put on the cyclist's leg.

Can you help me out on this? If you have other suggestions for cameras I could use with at least 60fps (and preferably 120fps) at a cost of max about 100€, that would be nice too...

Thanks!
Hans

11 (edited by leon 2021-May-15 17:17:49)

Re: Camera advise - Logitech C922 Problems

hello,

after I read that Joan called the Logitech about the best you can get, I bought one. but when I will track the Bikefit stickman it can't follow the markers and take an other spot, besides I need a bit bigger and more contrasting color for the marker, the camera is not performing as needed. I don't have the 60fps on my computer

i have set it to mjpeg, on the left top of the recording screen there is pixelrate @ 60 fps     signal 30 fps   
so I receive 1/2 the frames from the cam.

the exposure is not adjustable .

after updating windows 10 , disable the auto settings and lowlight option. I get 32pfs.  but nowhere near the 60fps

do I forget some settings on the cam. or is my computer to old/slow ?   ( the ports are usb3.0 )

thanks
leon