1 (edited by flyfly512 2019-Apr-03 10:27:21)

Topic: HELP!!! "Failure:unable to open the file: file not found or empty"

Hi there,
    Recently, I am always receiving  a warning message (Failure:unable to open the file: file not found or empty) from the kinovea 0.8.27 (64 bit) when I load videos from disks except C disk (where my operating system installed). And If I load a video more than 1 G, the warning message pops out even when the video loads from C disk. I have tried the editions released from the  website (kinovea?org), such as 0.8.27 (64 bit and 32 bit) and 0.8.15 (64 bit and 32 bit) , but the problems still cannot be solved .
    Many Thanks in advance!
Ren

Re: HELP!!! "Failure:unable to open the file: file not found or empty"

Hi,
The same file fails to load from one drive and loads fine from another or are they different files?
Do you have unicode characters in the file name? Are the other drives network drives or local? Is the path to the file on the other drive very long, like more than 260 characters? Are you on a Mac with Windows emulation/dual boot or on a Virtual machine? What is your Windows version? Is it 32bit or 64bit? Do you see the thumbnails for the files when you navigate to the drive using the built-in explorer?

Could you get to menu Help > Open log folder and send me log.txt and log.txt.1 by mail at joan at kinovea dot org or see if you can locate any relevant error and paste them here?
Thanks

Re: HELP!!! "Failure:unable to open the file: file not found or empty"

Hi Joan,
Thanks for ur quick reply. I try to read the log.txt. And I guess the file name (named with simple chinese) cannot be read by kinovea,the log.txt related as the following:
    "4269 - DEBUG - [5] - VideoReaderFFMpeg - Switching decoding mode. OnDemand -> NotInitialized
     4284 - ERROR - [5] - VideoReaderFFMpeg - The file C:\Users\lenovo\Desktop\1920-1080 ????? ??4? ???vs????
     ELTA HD 1080P ??1_Trim.mp4 could not be openned. (Wrong path or not a video/image.)
     4284 - ERROR - [5] - VideoReaderFFMpeg - The file C:\Users\lenovo\Desktop\20181212 ?????????? ????
     VS???.2[0]_Trim.mp4 could not be openned. (Wrong path or not a video/image.)"

SO, I solved the above problems by changing the file name and file path from simple chinese into Engligsh characters. BUT, Why my classmate's pc (HP, win10) can open a video named with chinese characters?
Thanks in advance!
Ren

Re: HELP!!! "Failure:unable to open the file: file not found or empty"

I think this relates to the behavior of the settings under Windows > Control panel > Region > Administrative > "Language for non-Unicode programs". Can you confirm if you guys have different values for this option? And if so, which one works?

One of the library for opening files doesn't have full support of Unicode and when it reads a file name it decodes it using a specific codepage, and I think this is where it may or may not work depending on whether that codepage is appropriate for the system locale.

Re: HELP!!! "Failure:unable to open the file: file not found or empty"

Joan,
Thanks a lot, I will check it soon.